Search | Running | Sailfish OS | All Posts | About Me

NetBSD on Raspberry Pi!

February 21, 2025 — Nico Cartron

The basics

  • burn the img to micro SD card
  • boot the RPi, it will resize then reboot
  • once booted, NetBSD login
  • login: root / (no password)
  • create user:
    • useradd -m -G wheel _user_
    • passwd _user_

Networking

  • I did the initial setup with an Ethernet cable plugged into the RPi,
  • For WiFi, NetBSD detected the RPi Wifi card as bwfm0

    • add the below to /etc/rc.conf:

      ifconfig_bwfm0="up"
      wpa_supplicant=YES
      
    • modify /etc/wpa_supplicant.conf with your Wifi settings, e.g.:

      network={
          ssid="MY_SSID"
          scan_ssid=0
          psk="MYPASSWORD"
          priority=5
      }
      

Configure packages

  • set the env variables as below:

    # PATH="/usr/pkg/sbin:/usr/pkg/bin:$PATH"
    # PKG_PATH="https://cdn.NetBSD.org/pub/pkgsrc/packages"
    # PKG_PATH="$PKG_PATH/NetBSD/aarch64/10.0/All/"
    # export PATH PKG_PATH
    
  • add pkgin with pkg_add pkgin to be able to install packages

  • we really only need a decent web browser, let's go for Surf:

    pkg_add surf
    

Testing

  • login with that user
  • startx works straight away

Current issue

The only real issue I have so far is that NetBSD does not use the entirety of the screen - see picas below:

I'm still figuring it out and will post an update - or write an article about it!

Going further

This article is a good summary of my experience with NetBSD:

NetBSD is a lightweight, compact, finely engineered system. It doesn't get
as much attention as its BSD cousins, not to mention Linux, but I just cannot
overstate how pleasant it is to use.

Tags: FreeBSD


I don't have any commenting system, but email me (nicolas at ncartron dot org) your comments!
If you like my work, you can buy me a coffee!